What algae is this, and how do i deal with it? - GTA Aquaria Forum - Aquarium Fish & Plants serving the Greater Toronto Area.
GTA Aquaria Forum - Aquarium Fish & Plants serving the Greater Toronto Area.

Go Back   GTA Aquaria Forum - Aquarium Fish & Plants serving the Greater Toronto Area. > PLANTED TANKS > Plants & Cultivation
Register FAQ Members List Calendar Advertise Search Today's Posts Mark Forums Read

Plants & Cultivation Discuss all topics regarding Plants, Growth, Fertilization, Water Parameters here.

Reply
 
Thread Tools Search this Thread Display Modes
Old 01-10-2017, 08:58 PM   #1
xenos369
Member
 
Join Date: May 2014
Location: Brampton
Posts: 132
Feedback Score: (4)
xenos369 is on a distinguished road
Question What algae is this, and how do i deal with it?

Ok so I have been really busy during the recent months with university work and i got the flu a couple weeks ago, so i have been slacking with some tank work. However, while 3 of my tanks are now in pristine condition, my 55 gallon is now coated with this new type of algae! Initially it was Blue-green algae which i dealt with using Algaefix and a whole lot of H2O2, but this new algae doesnt seem to be affected by the medication...

Anyone know what it is and how I can get rid of it? It is really stubborn, i dislodge it and siphon it but it just grows back and it doesnt respond to Algaefix. It is really slimy and has a yellowish-green color. BN Plecos and flagfish dont eat it, but pond snails seem to nibble on it.
Attached Images
File Type: jpg DSC_0392.jpg (114.9 KB, 43 views)
File Type: jpg DSC_0393.jpg (102.9 KB, 40 views)
File Type: jpg DSC_0394.jpg (70.1 KB, 38 views)
xenos369 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-10-2017, 09:09 PM   #2
carl
Devoted Member
 
carl's Avatar
 
Join Date: Feb 2010
Location: Toronto
Posts: 630
Feedback Score: (13)
carl has a spectacular aura about
Default

I have some amica Splendens that should take care of it, $4each
carl is offline   Reply With Quote
Old 01-10-2017, 09:10 PM   #3
planter
Aquascaping Apprentice
 
planter's Avatar
 
Join Date: Jun 2008
Location: Mississauga, ON
Posts: 1,363
Feedback Score: (30)
planter has a spectacular aura about
Default

Looks like green dust algae. Are you injecting co2?
planter is offline   Reply With Quote
 
Old 01-10-2017, 09:16 PM   #4
carl
Devoted Member
 
carl's Avatar
 
Join Date: Feb 2010
Location: Toronto
Posts: 630
Feedback Score: (13)
carl has a spectacular aura about
Default

Also check your filter and water flow in the tank, algae like that grows in stagnant water
carl is offline   Reply With Quote
Old 01-10-2017, 09:46 PM   #5
xenos369
Member
 
Join Date: May 2014
Location: Brampton
Posts: 132
Feedback Score: (4)
xenos369 is on a distinguished road
Default

Im not injecting any CO2, and im getting decent flow in my tank. Only thing lacking was water changes due to my busy schedule. Im now doing more PWC's but it isnt getting rid of my algae problem
xenos369 is offline   Reply With Quote
Old 01-11-2017, 11:12 PM   #6
planter
Aquascaping Apprentice
 
planter's Avatar
 
Join Date: Jun 2008
Location: Mississauga, ON
Posts: 1,363
Feedback Score: (30)
planter has a spectacular aura about
Default

It can be a pain in the butt. Clean as much as you can reduce the lighting and dose excel. Are you dosing ferts?

Check your co2 level as well.
planter is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:01 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.